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STOP

Atlas Scientific does not make consumer electronics.

This equipment is intended for electrical engineers. If you are not familiar
with electrical engineering or embedded systems programing, this product
may not be for you.

This device was developed and tested using a Windows computer. It was not
tested on Mac, Atlas Scientific does not know if these instructions are
compatible with a Mac system.
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Operating principle

The Wi-Fi hydroponics kit has been designed to provide the engineer with a simple way
of remotely monitoring and controlling a hydroponics system's chemistry. Sensor data
is uploaded to ThingSpeak ™, a free, cloud-based data acquisition and visualization
platform. The Wi-Fi hydroponics kit has also been designed to be easily modified by the
engineer. Feel free to change the sensors or functionality of the device to meet your
specific needs.

Overview
CPU

The Wi-Fi hydroponics kit is controlled using an Adafruit HUZZAH32 as its CPU. The
HUZZAH is programmed using the Arduino IDE and uses an onboard ESP32 as its Wi-Fi
transmitter. Adafruit HUZZAH32 datasheet.

11 L -
. 3v GND
([ XXXXXX)

Sensor ports

The Wi-Fi hydroponics kit PCB has 5 sensor ports. Three of the ports are electrically
isolated. The isolated ports are marked pH, Conductivity, and AUX. The isolated ports
are needed to take noise-free electrochemical readings. Because the sensing element of
a temperature sensor is never in direct contact with the water, electrical isolation is not
needed for temperature sensing.

The AUX port can be used to add an additional sensor of your choice. The terminal block
marked Port 5 has been designed to connect one or more dosing pumps to the device.
However, the port could also be used to connect a gas sensor.

AtlasScientific
Hydroponics Kit

Conductivity Temperature



https://learn.adafruit.com/adafruit-huzzah32-esp32-feather

PCB

The overall design of the PCB is quite simple. The CPU is powered and programmed
through the panel-mount USB connector. The CPUs USB pin supplies the board's power bus
with 5V.

Atla e O : o SEEE £
e :
dropo - o Huzzah ESP32 —=
—
°
O

Each of the four main sensor ports have an enable pin, which must be set correctly to
power the sensor. The enable pins are found here:

The first three pins (pH, Cond and Aux) must be set low to power on the sensor.
The last pin (Temp) must be set high to power on the sensor.

Truth table

Sensor Power
pH EN LOW
Cond EN LOW
Aux EN LOW

Temp EN HIGH O

Sensor port 5 (the terminal block) does not have an enable pin and can not be turned off.

. AtlasScientific
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Data protocol

The CPU communicates with all peripheral sensors using the 12C data protocol. All data
lines are directly connected to the CPUs I2C port. Using a different data protocol with this
circuit board is not possible.

It is important to keep in mind that all Atlas Scientific components default to UART mode.

When adding a new Atlas Scientific component to the kit, it must first be put into 12C
mode. Refer to the component's datasheet for instructions on how to switch it over.

Adding more of the same
sensor or component type

Adding additional components of the same type, such as an additional pH or conductivity
sensor, is not hard to do. As mentioned above, you must set the device to 12C mode, and
you must make sure that its I2C address is not the same as the already existing component.

AtlasScientifico
Hydroponics Kit -

pH VCC PRB PGND

20" @ @
Conductivity Temperature AUX
1 1
1 1

12C Address 12C Address 12C Address 12C Address
99 (0x63) 100 (0x64) Q/ 102 (0x66) « 99 (0x63)

- AtlasScientific
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This table lists the default 12C address of components commonly added to this kit.

12C Address

I12C Address

EZO EC 100 (0x64)
EZO RTD 102 (0x66)
EZO PMP 103 (0x67)

EZO pH 99 (0x63)

EZO ORP 98 (0x62)
EZO DO 97 (0x61)

Dosing pump

An optional external dosing pump can be added to the Wi-Fi hydroponics kit.
Using the EZO-PMP Advanced Kit is the simplest way to add on a dosing pump.

;Scienti_ﬁ_c o)

lrAanar® E

L1

Temperature

A stand-alone EZO-PMP can be used instead of the expansion pump kit; however, you
must manually put the pump in 12C mode and remove the data cable connector.

6 Copyright © Atlas Scientific LLC


https://atlas-scientific.com/ezo-pmp-advanced/

Uploading sensor data
to the cloud

The Atlas-Scientific Wi-Fi hydroponics kit has been designed to upload sensor data to
ThingSpeak™, a free, cloud-based data acquisition and visualization platform. You will be
required to set up a free account with ThingSpeak™ to upload and visualize the data. With
a free account, you can upload data once every 15 seconds. A paid account lets you
upload data once per-second; look here for more info about various ThingSpeak™
services.

Atlas Scientific has no business relationship with ThingSpeak™; we just like how it works.
If you want to use a different service, modify the device as you see fit.

Setting up your Wi-Fi kit
Ste p 1 Setup a ThingSpeak Account

Because the sensor data is stored / viewed on ThingSpeak, you will need
to setup a ThingSpeak account. Create your ThingSpeak account by clicking HERE.

D ThingSpeak" Channels Apps  Support~ Commercial Use  How to Buy

To use ThingSpeak, you must sign in with your existing MathWorks account or create a new one.

Non-commercial users may use ThingSpeak for free. Free accounts offer limits on certain functionality. Commercial users are eligible for a time-limited free evaluation. To
get full access to the MATLAB analysis features on ThingSeak, log in to ThingSpeak using the email address associated with your university or organization.

To send data faster to ThingSpeak or to send more data from more devices, consider the paid license options for commercial, academic, home and student usage.

Email

4\ MathWorks- % )

DATA AGGREGATION

—
‘ | o AND ANALYTICS
No EfU:(.Junl.‘? Create one! . . -_I Q Thingspeak
By signing in you agree to our privacy policy. f,.‘-‘;‘ NIATL!\B
v —
e 2 B
Next =l & Y
- T ¢ > /_". il I
—
i_’ SMART CONNECTED DEVICES g ;l.
2_' ALGORITHM DEVELOPMENT
SENSOR ANALYTICS

- AtlasScientific
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https://thingspeak.com/prices/thingspeak_standard
https://thingspeak.com/login

Ste p 2 Create a Channel

Your data is uploaded to ThingSpeak through a ‘Channel.” Select New Channel

|:| ThingSpeak“‘ Channels - Apps ~ Support~ Commercial Use How to Buy

My Channels Help
. S ¢ mriki Bariar Collect data in a ThingSpeak channel from a device,
e Search by tag EI from another channel, or from the web.

Click New Channel to create a new ThingSpeak
channel.

Click on the column headers of the table to sort by the
entries in that column or click on a tag to show
channels with that tag.

|:| ThingSpeak“ Channels~ | Apps~  Support~ Commercial Use ~ How to Buy

New Channel Help

Channels store all the data that a ThingSpeak application collects. Each channel includes

Name Atlas Sensors
eight fields that can hold any type of data, plus three fields for location data and one for
status data. Once you collect data in a channel, you can use ThingSpeak apps to analyze and
Description visualize it.
Channel Settings
Field 1 pH * Percentage complete: Calculated based on data entered into the various fields of a
channel. Enter the name, description, location, URL, video, and tags to complete your
channel.
Field 2 EC (uS/cm)
* Channel Name: Enter a unigque name for the ThingSpeak channel.
Field 3 Temp (°C) » Description: Enter a description of the ThingSpeak channel.

Fill out the highlighted boxes. (Be sure to click on the checkboxes to enable field 2 and 3)
For reference, this is what we entered.

Name Atlas Sensors
Field1 pH

Field 2 EC (uS/cm)
Field 3 Temp (°C)

Scroll to the bottom of the page and click Save Channel.

- AtlasScientific
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Ste p 3 Get ThingSpeak API keys

After you saved your channel settings, you will be redirected to your channel page.
Click on API keys.

|:| ThingSpeak“‘ Channels ~ Apps ~ Support~ Commercial Use How to Buy

My Channels Help
. S N Collect data in a ThingSpeak channel from a device,
S EI from another channel, or from the web.

Click New Channel to create a new ThingSpeak
Name Created Updated channel.
Click on the column headers of the table to sort by the

entries in that column or click on a tag to show
channels with that tag.

& Atlas Sensors 2020-02-14 2020-05-1123:04

l Private ‘ Public ‘ Settings | Sharing ‘ APl Keys ‘ Data Import / Export

Learn to create channels, explore and transform
data.

Learn more about ThingSpeak Channels.

I:l ThingSpeak“ Channels ~ = Apps~  Support~ CommercialUse  How to Buy

Atlas Sensors

Channel 1D: XXXXXX
Author:
Access: Private

Private View Public View Channel Settings Sharing APl Keys Data Import / Export

Write API Key Help

AP keys enable you to write data to a channel or read data from a private channel. APl
keys are auto-generated when you create a new channel.

Key 00 0.0.0.0.6.4.0.4.9.6.44
APl Keys Settings
* Write API Key: Use this key to write data to a channel. If you feel your key has

been compromised, click Generate New Write API Key.
o Read API Keys: Use this key to allow other people to view your private channel

Be sure to save your Channel ID and Write API Key we are going to need these, in the
next few steps.

- AtlasScientific
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Ste p 4 Make sure your Arduino IDE libraries are up to date

A Make sure you have the correct path for the Esp32 Library

In the IDE, go to File > Preferences
Locate the Additional Boards Manager URLS text box.

Preferences >

Settings  Metwork

Sketchbook location:

= Browse
Editor language: System I:!Efﬁu!t «w | (reguires restart of Arduinao)

Editor font size: 12

Interface scale: Automatic | 100 S % (requires restart of Arduing)

Theme: Default theme -~ | (requires restart of Arduino)

Show verbose output during: [ ] compilation [ ] upload

Compiler warnings: N:.;nne o

Display line numbers [] Enable Code Folding

Verify code after upload [] Use external editor

Check for updates on startup Save when verifying or uploading

[] Use accessibility features

Additional Boards Manager URLs:  https:/fraw.githubusercontent. com/fespressif/arduino-esp32/ah-pages/package_esp32_index.json ﬁ

0K Cancel

Make sure this URL is in the textbox

https://raw.githubusercontent.com/espressif/arduino-esp32/gh-pages/package_esp32_index.json
Click OK.

- AtlasScientific
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B Update the esp32 board

In the IDE, go to Tools > Board > Boards Manager

File Edit Sketch Tools Help

hydroponics_K

enum reading |
f/atep 1 tell
f/atep 2 cons
/fstep 4 tell
//atep 3 cons

enum reading_|

bool polling
bool send to_|

int return_cof
uint32_t next|
const unsigne
unsigned int

const unsigne|

const unsigne
const unsigne|

void setup()

pinMode (EN |

Auto Format

Archive Sketch

Fix Enceding & Reload
Manage Libraries...
Serial Monitor

Serial Plotter
WiFi101 / WiFiNINA Firrnware Updater

Board:

Upload Speed: "115200"

CPU Frequency: "80 MHz"

Flash Size: "4MB (F5:2MB OTA:~1019KB)"
Debug port: "Disabled”

Debug Level: "None"

IwlP Variant: "v2 Lower Memory"

VTables: "Flash"

Exceptions: "Legacy (new can return nullptr)”
Erase Flash: "Only Sketch"

S5L Support: "All 551 ciphers (most compatible)”
Part

Get Board Info

Programmer: "AVRISP mkll”

Burn Bootloader

Ctrl+T

Ctrl+Shift+1
Ctrl+Shift+M
Ctrl+Shift+L

WICES, READ RESPONSE };

g we just received

Boards Manager...

fi
Arduino AVR Boards

Arduino Yin

Arduine Uno

Arduine Duemilanove or Diecimila
Arduine Mano

Arduine Mega or Mega 2560
Arduine Mega ADK
Arduine Leonardo

Arduine Leonarde ETH
Arduine Micro

Arduine Esplora

Arduine Mini

Arduine Ethernet

pinMode (EN_reo;

UUITUIT

@ Boards Manager X
Type | Al w | lesp32

esp32 ~

by Espressif Systems version 1.0.5 TNSTALLED

Boards included in this package:

ESP32 Dev Module, WEMOS LoLin32, WEMOS D1 MINI ESP32.

More Info

|Select version ~ | | Install Update || Remove

v
Close

In the search bar of the Boards Manager, lookup esp32.
Update to the most recent version if you don't already have it.

(Version 1.0.5 in not the most recent version)

11 Copyright © Atlas Scientific LLC
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C Download the ThingSpeak library for Arduino

Click HERE to download the latest version of the ThingSpeak library.
Don’t unzip it!

Import the .ZIP file into your Arduino IDE.
To import the .ZIP file go to Sketch > Include Library > Add .ZIP Library

File Edit Sketch Tools Help

Verify/Compile Ctrl+R
Upload Ctrl+L
hydrop Upload Using Programmer  Ctrl+Shift+U

Export compiled Binary Ctrl+Alt+5
£NUN e D COMPENSATE, REQUEST DEVICES, BRELD RESPONSE }:
ffatep Show Sketch Folder Ctrl+K ng
i) Include Library | A
:::::EZi Add File... Manage Libraries... Ctrl+5Shift+|

Add ZIP Library...

D Add the EZO 12C Library

To download the Ezo_I2c¢ library file, click HERE.

¥ master ~ F 1branch D 0tags Go to file

2] Clone @

HTTPS  GitHub CLI

@ Atlas-5Scientific removed redundant examples, aquaponics kit has pump code by ¢

Examples removed redundant examples, aquapon NEED= " aa iRl COMAE TS = c e Ata T3y |
O Ezo_i2ccpp added the get_address() method to the  Use Git or checkout with SVM using the web URL.
D Ezo_i2ch added the get_address() method to the

¥ Open with GitHub Desktop

[M Ezo_i2c_util.cpp Created libraries for common functions
M Ezo_i2c_utilh Created libraries for common functions  [§) Download ZIP
[ LICENSE Initial commit 2 years ago
™ READMEmd Update README.md 18 days ago

Don’t unzip it!
Import the .ZIP file to your Arduino IDE.
To import the .ZIP file go to Sketch > Include Library > Add .ZIP Library

- AtlasScientific
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https://www.arduinolibraries.info/libraries/thing-speak
https://github.com/Atlas-Scientific/Ezo_I2c_lib

Ste p 5 Flash the Hydroponics meter with the correct code

A Select, open and adjust the code you want to use for your Wi-Fi Kit

File> Examples> EZO_I2C_lib-master> Examples> IOT_kits> hydroponics_kit

File Edit Sketch Tools Help

Mew Ctrl+M
Open... Ctrl+ O
Open Recent
Sketchbook
Examples 3 & ifi hydroponics kit that uses the
Ciose ChleW ESP32 BLE Arduino
Save Ctrl+5 ESETIRE
SaveAs..  Ctrl+ShiftsS e AEAnEnR:
HTTPClient //include
Page Setup  Ctrl+5Shift+P HTTPUpdate //importe
Print Ctrl+P HTTPUpdateServer //imports
Preferences  Ctrl+Comma NetBlOS
Preferences
. b 3
Quit Ctrl+Q SD(esp32) Bc library
L SD_MMC
12 WiFiClient clien SimpleBLE
13
SPI F ’
14\ /= ingSpsak Credentials—————-
X y SPIFFS »
15 |const String ssi
o F Ticker
l6 |const String pas
17 |const long myCha Hpe
18 |const char * myW PRehScres KHEXHX" ;
g -1 SR R L wE
20 WiFiClientSecure
WiFiProv

1 Ezo _board PH
22 Ezo_board EC

1]
ul

SdiEmorBeped BID = ACROBOTIC SSD1306
24 E b d PMP =
e e Adafruit BME280 Library
25

, Adafruit BMEGSD Library
26 Ezo board device
k! = 1 Adafruit ESPB266
27 PH,
oy Adafruit HTU21DF Library
28 EC; ) )
55 RTD, Adafruit SHT31 Library
30 BMP Adafruit 517021 Library
313; atlas_grawity
35 EspSoftwareSerial

Ezo_|2c_lib-master

33 Ezo_board* defau
4 Ezo_uart_lib-master

35 //gets the lengt PID
36 |/const uint8 t de StepperDriver
ThingSpeak
INCOMPATIBLE
v

Examples from Custom Libraries

Examples : 12¢_lib_examples * L,F,

Adafruit huzzah32 as its computer.

wifi library
thingspeak library
a 4 function sequencer

a 1 function segquencer

//brings in common print statements

[ library from https://github.com/Atlas-Scientific/Fzo I2c lib

//declare that this device connects to a Wi-Fi ns

//The name of the Wi-Fi network you are connect:
f/Your WiFi network password

//Your Thingspeak channel number

//Y¥our ThingSpeak Write API Eey

f/create a PH circuit object, who's address is 99 and name is "PH"
//create an EC circuit object who's address is 100 and name is "EC"
//create an RTD circuit object who's address is 102 and name is "RTD"

//create an PMP circuit ckject who's address is 103 and name is "EME"

//an array of boards used for sending commands to all or specific boarc

talkinag to

10T _kits
Lly so we Projects

Sequencer_lib_sxamples

rice list)

13 Copyright © Atlas Scientific LLC

aquapenics_kit
hydroponics_kit
legacy_hydroponics_kit

add new boards

legacy_hydroponics_kit_with_DO
pool_kit

thingspeak_example

- AtlasScientific
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B Fill in your Wi-Fi / ThingSpeak credentials

Fill in your Wi-Fi name and Password, along with the Channel ID and Write API Key to the
code. (see step 3)

finclude <iot_cmd.h>

[T

finclude <WiFi.h> //include wifi library

5 finclude "ThingSpeak.h" //include thingspeak library

& #include <sequencer4.h> f/imports a 4 function segquencer

7 #include <sequencerl.h> //imports a 1 function seguencer
finclude <Ezo iZ2c util.h> //brings in common print statements

finclude <Ezo_i2c.h> //include the EZO I2C library from https://github.com/Atlas-Scientific/Ezo I2c lib

LR T <]

) #include <Wires.h> //include arduinos iZ2c library

g |
12 WiFiclient client; //declare that this device connects to a Wi—-Fi network,c
13
B e e e Fill in your Wi-Fi / Thinggbeak Credentials———--———
15 const String ssid = "Wifi Name"; //The name of the Wi-Fi network you are connecting to
16 const String pass = "Wifi Password"; //Your WiFi network password
17 const long myChannelNumber = 1234566; //Your Thingspeak channel number
18 const char * myWriteAPIEKey = "000000D00D0000DH"; /{Your ThingSpeak Write API Eey
L=

A === e e S e e S e

C Setting up your pump

If you do not have a pump attached, you can just skip this part. The code is rather
self explanatory. You set what parameters will trigger the pump to engage.

f3
(==}

1
o

) |/ /parameters for setting the pump output

50 §define PUMP_BOARD PMP //the pump that will do the output (if theres more than one)

51 #define PUMP_DOSE -0.5 //the dose that the pump will dispense in milliliters

52 f#define EZO_BOARD EC //the circuit that will be the target of comparison

53 f#define IS GREATER THAN true //true means the circuit's reading has to be greater than the comparison value,
54 #define COMPARISON VALUE 1000 //the threshold above or below which the pump is activated

i
wn

- AtlasScientific
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Ste p 6 Setting up the HUZZAH board

A Set the target CPU to flash

Tools> Board> ESP32 Arduino > Adafruit ESP32 Feather

File Edit Sketch Tools Help

Auto Format
Archive Sketch
' Fix Encoding & Reload

hydropanics T

Manage Libraries...
1//This Serial Monitor
2 Serial Plotter
3 |finclu
4 |$inclu WIF101 / WiFiNINA Firmware Updater
5 finclu

Board: "Adafruit ESP32 Feather”
Upload Speed: "921600"

Flash Frequency: "80MHz"
Partition Scheme: "Default”

& #Finclu
finclu
8 |finclu

9 finclu
Core Debug Level: "Mone”

Port
Get Board Info

10 | finclu

12 WiFicCl
13 Programmer
14| ff———— Burn Bootloader

Ctrl+T

Ctrl+5Shift+]
Ctrl+5Shift+ M
Ctrl+Shift+L

Boards Manager...

i hydroponics kit that uses the Adafruit I

ffinclude wifi libre
ffinclude

ffimports

thingspeal

a 4 functj]

Arduino AVE Boards
E5SP32 Arduino
ESP8266 Boards (3.0.1) *

Y I e e

library

\gSpeak Credential

String ssid = "Wifi Name=";

String pass =

"Wifi Password";

17 const long myChannelNumber = 1234366;

21 |Ezo _board FH Ezo board (5%,
22 Ezo board EC = Ezo board(100,
23 Ezo board RTD = Ezo board (102,

TA Barm emmard TR — Teaems e naA 0T 02

15 Copyright © Atlas Scientific LLC

“PH“} :
chu} 5
r

n RTDII } ;

Wrnam iy o

char * myWriteAPIEey = "“3000000000DN0NIONK";

/{fcreate a PH circ
an EC cir

an RTD ci

/fecreate

/fecreate

TIRATY

g RN - R S

Fy
ESP32 Wrover Module

ESP32 Pico Kit

TinyPICO

5.0D1 Ultra v1

MagicBit

Turta loT Node

TTGO LoRa32-OLED W1
TTGa T

TTGO T7 V1.3 Mini32
TTGO T7 V1.4 Mini32

Adafruit ESP32 Feather
SparkFun ESP32 Thing
SparkFun ESP32 Thing Plus
u-blox MINA-W10 series (ESP32)
Widora AIR

Electronic SweetPeas - ESP320

- AtlasScientific
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B Adjust CPU Settings

Make sure the CPU settings on the Adafruit HUZZAH32 are correct.
To adjust the CPU settings, click Tools.

For reference, this is what Atlas Scientific set the CPU settings to.
(your options may not be exactly the same, just try and match them as closely as possible.)

File Edit Sketch Tools Help

Auto Format Cirl+T
Archive Sketch
hydroponics_k Fix Encoding & Reload
1 #includs Manage Libraries... Ctrl+Shift+|
2 #includ: Serial Monitor Ctrl+Shift+M
@ #includd  gerial Plotter Ctrl+Shift+L

4 | #includs
¥includs W01 S WiFiININA Firmware Updater

in

¥includs

o

E Board: "Adafruit ESP32 Feather” >
s Upload Speed: "921600" 3
#includs S
a Flash Frequency: "20MHz" ¥
10 WiFiclid Partition Scheme: "Default” >
11 Core Debug Level: "None" ¥
12 |/ f—————1 Port: "COMSE" 3
13 const Si Get Board Info
14 lconst 51
Programmer #

Burn Bootloader

. AtlasScientific
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Ste p 7 See the readings

Open your Arduino serial monitor.

(You must have the serial monitor set to the com port from the Adafruit HUZZAH32)

O

[ send |

Autoscroll [ Show timestamp

Carriage return -

2| oo

Set to carriage return and 9600 baud.

The Wi-Fi Hydroponics Meter will always attempt to connect to ThingSpeak on bootup.

2 — O ot
| send |

RTD: 25.90 PH: 4.4% EC: 14¢6.40

ETD: 25.91 PH: 4.49 EC: 146.40

RTD: 25.91 PH: 4.49 EC: 146.30

RTD: 25.91 PH: 4.4% EC: 146.30

RTD: 25.91 PH: 4.4% EC: 14¢.30

RTD: 25.91 PH: 4.49 EC: 14¢.30

sent to thingspeak

RTD: 25.90 PH: 4.4%9 EC: 146.40

ETD: 25.91 PH: 4.49 EC: 146.40

RTD: 25.91 PH: 4.49 EC: 146.30

RTD: 25.91 PH: 4.4% EC: 146.30

RTD: 25.91 PH: 4.4% EC: 14¢.30

RTD: 25.91 PH: 4.49 EC: 14¢.30

sent to thingspeak

RTD: 25.90 PH: 4.49 EC: 146.40

ETi- 96 &1 pDH- 4 4G B 146 40

[«] Autoscrall [ ] Show timestamp Carriage return v| |9500 baud v| | Clear output

17 Copyright © Atlas Scientific LLC
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If it cannot connect to your Wi-Fi you will see this:

oc) — | et

RTD: 25.76 PH: 4.49% EC: 143.20
RTD: 25.76 PH: .49 EC: 143.20
RTD: 25.76 PH: .49 EC: 143.20
RTD: 25.76 PH: 4.4% EC: 143.00
connecting to wifi

RTD: 25.76 PH: 4.4% EC: 143.00
RTD: 25.76 PH: 4.49 EC: 143.00
RTD: 25.76 PH: 4.49 EC: 143.00
RTD: 25.76 PH: 4.49 EC: 142.80
connecting to wifi

RTD: 25.76 PH: 4.49 FEC: 143.20
RTD: 25.76 PH: 4.49 EC: 143.20
RTD: 25.76 PH: 4.49 EC: 143.20
RTD: 25.76 PH: 4.49% EC: 143.00
connecting to wifi

RTD: 25.76 PH: 4.49% EBEC: 143.00
RTD: 25.76 PH: 4.49 FEC: 143.00
RTD: 25.76 PH: 4.49 EC: 143.00
BTD: 25,76 PH;: 4,49 EC: 142,80

Autoscroll [ ] Show timestamp |Earr1'age return - | |SEUU baud e | | Clear output |

LN S 8

Entering the poll command will stop the Wi-Fi Hydroponics Meter from uploading the
readings to thingspeak, while you debug your Wifi problems.

- AtlasScientific
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Step 8 Sensor Calibration

Atlas Scientific created a list of calibration commands that are built into the library.
Type in help to see a list of commands.

@E - | P
Send

> help

Atlas Scientific I2C hydroponics kit

Commands:

datalog Takes readings of all sensocrs every 15 sec send to thingspeak

Entering any commands stops datalog mode.

poll Takes readings continucusly of all sensors

ph:cal, mid, 7 calibrate to pH 7

ph:cal, low, 4 calikbrate to pH 4

ph:cal,high, 10 calikbrate to pH 10

ph:cal, clear clear calibration

ec:cal,dry calibrate a dry EC probe

ec:k, [n] used to switch E values, standard probes values are 0.1, 1, and 10

ec:cal,clear clear calibration

For K1 probes, these are the recommended calibration values:

ec:cal, low, 12880 calibrate EC probe to 12, 880us
ec:cal, high, 80000 calibrate EC probe to 80, 000us
rtd:ical, t calibrate the temp probe to any temp value

t= the temperature you have chosen

rtd:cal,clear clear calibration

Autoscroll [] Show timestamp Carriage return -~ | 9600 baud e Clear output

A The poll command

Send the command poll; This will let you see the readings once per second and it will stop
uploading to ThingSpeak while you calibrate.

- AtlasScientific
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B Calibrate pH

Remove the soaker bottle and rinse off the pH probe. Remove the top of the pH
7.00 calibration solution pouch. Place the pH probe inside the pouch and let the probe sit
in the calibration solution until the readings stabilize. This will take about 1 — 2 mins.

1-2 mins

6.917

7.126 — X Unstabilized
7.223 |
7.225

7.225

25 — & Stabilized
7.225 | Once the readings have stabilized,

ph:cal,mid,7 issue the Mid point calibration

*OK command. ph:cal,mid,7
7.000
7.000

Rinse off the probe and repeat this process for both pH 4.00 and pH 10.00.

C Calibrate Conductivity

When calibrating Conductivity, you must always calibrate a dry probe first.

Make sure that the probe is dry before issuing this command, ec:cal,dry

. AtlasScientific
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Once the dry calibration has been completed, place the probe into a small cup of the
12,880pS calibration solution. Shake the probe to make sure you do not have trapped
air bubbles in the sensing area. You should see readings that are off by 1 — 40% from
the stated value of the calibration solution. Wait for readings to stabilize.

12,880pS 12,880pS

check probe connection,

Trapped air in sensing
you cannot calibrate to 0.

area (shake to remove)

16,247 |
15,491 — X Unstabilized
18,055 ]
13,756

13,756 o
13756 —Q/Stablllzed

13,756 Once the readings stabilize, issue the low point
ec:cal,low,12880 calibration command. ec:cal,low,12880

*OK (Readings will NOT change)

13,756
13,756

Rinse off the probe before calibrating to the high point. Pour a small amount of the 80,000uS
calibration solution into a cup. Shake the probe to remove trapped air. Again, the readings
may be off by 1 — 40% Wait for readings to stabilize.

— O X
51,674
53,826 — X Unstabilized
55,193
56,493

56,493 -
56,493 —\/Stablllzed

56,493 Once the readings stabilize, issue the high point
ec:cal,high,80000 calibration command. ec:cal,high,80000

*OK (Readings will change, calibration complete).
80,000
80,000
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21 Copyright © Atlas Scientific LLC #—————————Environmental Robotics



D Calibrate Temperature

Calibrating the PT-1000 temperature probe is not required. However, if you want to,
a simple method to calibrate the probe is to place the PT-1000 into boiling water. Then
issue command rtd:cal,t

100 °C

Elevation in meters

305
229
152
76

0
-76
-152

Calibration Complete
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Step 9 imostdone

Once you are finished with calibration, issue the datalog command to resume taking a

reading every 15 seconds and uploading it to thingspeak.

To see the data on your phone, download the ThingSpeak app.

Max 36
0N 19 Sap, 1.
Onlﬂsq”z" ep 12:32

1
2% iy

1240

Setup Complete!
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